Back to overview
Servidor Iniciando
Dec 20, 2025 at 7:47am UTC
Affected services
Minecraft Server
Resolved
Dec 20, 2025 at 7:47am UTC
Pure Forge Server & additional services are running & Ready
Affected services
Resolved
Dec 20, 2025 at 7:47am UTC
Pure Forge Server & additional services are running & Ready
Affected services