Back to overview
Service Restart to apply updates
Dec 22, 2025 at 5:47am UTC
Affected services
Minecraft Server
Resolved
Dec 22, 2025 at 5:47am UTC
Service back online
Affected services
Resolved
Dec 22, 2025 at 5:47am UTC
Service back online
Affected services